Reprocessing Yahoo Inc. Inbox Rates
Incident Report for eDataSource
Postmortem

Summary

On 7 June Yahoo changed their main Spam IMAP Folder from ‘Bulk Mail’ to ‘Bulk’.  Our consumer panel harvesters collect email via IMAP and we were unable to retrieve any spam from 7 June - 11 July.  This caused an over reporting of Inbox rate within Inbox Tracker and Competitive Tracker.

How was it detected?

Reported by client that detected anomaly in custom report output for the month of June.

Resolution

We updated our IMAP folder mappings to allow Spam content from the “Bulk” folder for all Yahoo ISPs.

Harvest limits were then extended to query all Yahoo Consumer Panel accounts. Retrieving uncollected Spam results. Spam messages are only kept for 30d in the Yahoo IMAP system so some days were not recoverable. (Note:  Because of duplicate message guard-rails that are in place this action had to be completed in less than 48 hours to ensure we did not process anything twice.)

Contributing Factors

Lack of IMAP harvest monitoring on specific IMAP folders caused the outage to be much longer than would normally be expected.

Customer Impact

All customers reviewing Yahoo data between 7 June - 11 July would have been affected with higher inbox rates for all sending domains during that time.

  • Data between 11 June - 11 July has now been updated with harvested Spam data for Inbox Tracker and Competitive Tracker data

Corrective actions

We are now working to actively monitor all Intelliseed ISPs for IMAP folder changes and alert the team when new IMAP folders are detected or mapped Inbox/Spam folders do not receive mail.

Posted Jul 21, 2022 - 16:54 EDT

Resolved
Our reprocessing of Yahoo Inc inbox rates is now complete.
We have reprocessed inbox rates all Yahoo Inc. email received between 11 June - 11 July.
Posted Jul 13, 2022 - 12:05 EDT
Monitoring
We are currently reprocessing data for Yahoo Inc.
Posted Jul 11, 2022 - 12:09 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 11, 2022 - 10:46 EDT
Identified
We have identified an issue causing higher than usual inbox rates for Yahoo Inc. ISP.
Yahoo, AOL, and AT&T Inbox/Spam rates are being reprocessed at the current time for Consumer Panel results.
While we reprocess this data, please use our Yahoo Insights feature for current Inbox/Spam rates.
Posted Jul 11, 2022 - 10:42 EDT
This incident affected: Analyst NextGen Client, V4 API, Deliverability - Analytics Tracker, Deliverability - Traditional Seed, Inbox Tracker, Competitive Tracker, and SFMC - Inbox Tracker.