Google Postmaster Tools Delayed Data
Incident Report for eDataSource
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 09:27 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 15, 2024 - 09:26 EDT
Identified
Google Postmaster Tools data has not been updated in Inbox Tracker since 5 Jul 2024. This is an issue at Google and appears to be impacting all Google Postmaster Tools users. Google Postmaster Tools data will backfill as soon as it is available.

We will update the Google Postmaster Tools data in Inbox Tracker once it is available.
Posted Jul 10, 2024 - 10:02 EDT
This incident affected: Deliverability - Postmaster Tools.