Higher than normal Inbox Rates at Hotmail/Outlook
Incident Report for eDataSource
Resolved
This incident has been resolved, Inbox Rates are now back to normal levels.
Posted Feb 20, 2023 - 13:35 EST
Monitoring
We are currently monitoring the Inbox Rates.
Posted Feb 20, 2023 - 07:38 EST
Investigating
We have identified and are currently monitoring higher than usual inbox rates for the Hotmail/Outlook ISP.
Panel and Intelliseed source are both reflecting higher than normal Inbox rates at this time and we are attempting to reach out to the provider.
Posted Feb 20, 2023 - 07:38 EST
This incident affected: Analyst NextGen Client, V4 API, Deliverability - Analytics Tracker, and Inbox Tracker.