Reduced Inbox Rate at Outlook
Incident Report for eDataSource
Resolved
Starting at approximately 0400UTC on 16 March the inbox rates at Outlook returned to normal. This has continued throughout the day. We consider this issue to be resolved.
Posted Mar 16, 2023 - 20:02 EDT
Update
Most senders are seeing a vast improvement in Inbox Rate over the last 12 hours at Outlook. We will continue to monitor the situation for the rest of the day.
Posted Mar 16, 2023 - 11:11 EDT
Monitoring
This issue is still occurring however we have noticed that some senders are starting to return to normal inboxing at Outlook. We have reached out to Microsoft to determine when this issue will be resolved however we have not received a response. We will continue to monitor the situation
Posted Mar 15, 2023 - 14:34 EDT
Investigating
Several senders have reported a significant drop in inbox rates at Outlook starting on 10 March 2023. This is an issue at Outlook and it is being investigated.
Posted Mar 13, 2023 - 16:06 EDT
This incident affected: V4 API, Deliverability - SNDS, Inbox Tracker, Competitive Tracker, and SFMC - Inbox Tracker.