Partial outage

Incident Report for eDataSource

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 11:53 EDT

Update

Our cloud provider is reporting recovery across most affected services. We continue to monitor the situation closely and will provide updates if anything changes.
Posted Oct 20, 2025 - 06:19 EDT

Monitoring

The impact on our services is decreasing and we have not observed any additional issues with other services. We continue to monitor the situation closely.
Posted Oct 20, 2025 - 05:34 EDT

Investigating

Our cloud provider (Amazon AWS) is currently experiencing an incident that's impacting some of our data processing services. This issue is external to our systems. Our team is actively investigating to determine if there are any additional impacts and working to minimize downstream effects while our provider implements a fix.

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 04:36 EDT
This incident affected: Amazon Web Services (AWS ec2-us-east-1, AWS rds-us-east-1) and Analyst NextGen Client, Deliverability - Analytics Tracker, Deliverability - Traditional Seed, Deliverability - Postmaster Tools, Deliverability - SNDS, Spam Trap Monitor, Inbox Tracker, Competitive Tracker, SFMC - Inbox Tracker, Deliverability - DMARC, Design Tracker.