Inbox Tracker unavailable

Incident Report for eDataSource

Resolved

The incident has been resolved.
Posted May 27, 2025 - 04:24 EDT

Investigating

We are currently investigating the unavailability of Email Tracker - app.emailanalyst.com
Posted May 27, 2025 - 03:40 EDT
This incident affected: Inbox Tracker.