Google Postmaster Tools Not Available After 27 April 2022
Incident Report for eDataSource
Resolved
The Google Postmaster Tools data is now current. All data is available in Inbox Tracker.
Posted May 03, 2022 - 15:00 EDT
Monitoring
We have started to receive data from Google Postmaster Tools however data for April 28th and 29th is not available. We will provide this data IF Google makes it available. We will continue to monitor this incident.
Posted May 03, 2022 - 09:16 EDT
Identified
Google Postmaster Tools data has not been updated in Inbox Tracker since 27 April 2022. This is an issue at Google and appears to be impacting all Google Postmaster Tools users. The Google Postmaster Tools website is also missing data after 27 April 2022.

We will update the Google Postmaster Tools data in Inbox Tracker once it is available.
Posted May 02, 2022 - 08:35 EDT
This incident affected: Deliverability - Postmaster Tools.